Laravel / May 20, 2014

Laravel 4.1.29 released

Laravel 4.1.29 improves the column quoting for all database drivers. This protects your application from some mass assignment vulnerabilities when not using the fillable property on models. If you are using the fillable property on your models to protect against mass assignemnt, your application is not vulerable. However, if you are using guarded and are passing a user controlled array into an “update” or “save” type function, you should upgrade to 4.1.29 immediately as your application may be at risk of mass assignment.

To upgrade to Laravel 4.1.29, simply composer update. No breaking changes are introduced in this release.

It is important to get this upgrade for the mass assignment updates.

Laravel News Partners

Newsletter

Join the weekly newsletter and never miss out on new tips, tutorials, and more.