Testing Composer Dependencies with prefer-lowest

News

December 19th, 2014

Evert Pot has a new post explaining the new --prefer-lowest composer flag and explains why you should use it in your testing.

To give your users the smoothest experience possible, it’s therefore best to try to nail down the oldest possible dependencies your package can still work with, and only increase that minimum version if you’re depending on the latest introduced feature, or to get around an major bug.

Filed in:

Eric L. Barnes

Eric is the creator of Laravel News and has been covering Laravel since 2012.